Prérequis

Pour utiliser WordPress, votre hébergeur devrait supporter :

  • PHP version 7.2 ou supérieure.
  • MySQL version 5.6 ou supérieure OU MariaDB version 10.0 ou supérieure.
  • Prise en charge du HTTPS

C’est réellement cela. Nous recommandons Apache ou Nginx comme serveurs les plus robustes et les plus fonctionnels pour l’exécution de WordPress, mais tout serveur supportant PHP et MySQL conviendra. Cela dit, nous ne pouvons pas tester tous les environnements possibles et chacun des hébergeurs listé sur notre page dédiée prend en charge ce qui précède et bien plus sans aucun problème.

Note : si vous êtes dans un environnement hérité où vous avez uniquement des anciennes versions de PHP ou MySQL, sachez que WordPress fonctionne aussi avec PHP 5.2.4+ et MySQL 5.0+, mais ces versions sont en fin de vie et peuvent exposer votre site à des failles de sécurité.

Demandez-le

Voici une lettre que vous pouvez envoyer à votre hébergeur ; copiez-collez la !

Je souhaite utiliser le logiciel libre WordPress et les services web proposés par https://wordpress.org/ et je me demandais si mon compte était compatible avec ce qui suit :

  • PHP 7.2 ou plus élevé
  • MySQL 5.6 ou plus élevé OU MariaDB 10.0 ou plus élevé
  • Nginx ou Apache avec le module mod_rewrite
  • Prise en charge du HTTPS

Merci !

Facultatif, mais recommandé pour plus de sécurité

L’hébergement est plus sécurisé lorsque les applications PHP, comme WordPress, sont exécutées en utilisant le nom d’utilisateur de votre compte, plutôt qu’un nom d’utilisateur partagé par défaut du serveur. Demandez à votre hébergeur potentiel quelles mesures sont mises en place pour assurer la sécurité de votre compte.